WhatsApp Web

Nuevos requisitos de desarrollador para Google Play Store

Google ha anunciado recientemente la aplicación de seguridad y cambios de rendimiento para los desarrolladores de Google Play. Estos cambios incluyen la necesidad de nuevas aplicaciones y actualizaciones de las aplicaciones existentes para atacar el nivel más reciente de la API de Android, obligatoria 64-bit App versiones de 2019, y la adición de metadatos de seguridad a cada apk.

 

La primera actualización requiere de todas las nuevas aplicaciones y actualizaciones para las aplicaciones existentes para el objetivo de nivel de API 26 (Android 8,0 Oreo) o superior.

 

Cada año el nivel de API avanzará requiriendo nuevas apps y actualizaciones de App para apuntar el nivel de API correspondiente o superior.

 

La segunda actualización es con respecto a 64-bit soporte para aplicaciones. Mientras que la arquitectura de 64 bits para aplicaciones se introdujo por primera vez en Android 5,0, la actualización requiere que los desarrolladores de aplicaciones envíen una biblioteca de 64 bits obligatoria dentro de cualquiera de sus servidores enviados. Este mandato llegará a su lugar antes del 2019 de agosto. Las aplicaciones que no incluyen código nativo no se ven afectadas.

 

El iOS 11 de Apple recientemente hizo el cambio grande a la arquitectura de 64 bits terminando el soporte para las bibliotecas de 32 bits en junio de este año.
Google también ha anunciado que sería la adición de metadatos de seguridad en la parte superior de cada apk para comprobar que fue distribuido oficialmente por Google Play.

 

Este cambio no requerirá ninguna acción o cambio de los desarrolladores o usuarios. En su lugar, se insertará en el bloque de firma de apk, por lo tanto no alterar la funcionalidad de la aplicación. Se espera que estos metadatos actúen como una divisa de autenticidad del juego para la aplicación Android.
Nuestra nota
Rating
[Total: 0 Average: 0]
Más de:

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *